Degraded performance of Trello

Incident Report for Trello

Resolved

On Thursday, September 11, 2025 1:00PM UTC, Trello users may have experienced performance degradation. The issues has now been resolved, and the service is operating normally for all affected customers.
Posted Sep 11, 2025 - 10:18 EDT

Monitoring

The performance degradation of Trello has been resolved, and services are now operating normally for all affected customers. We'll continue to monitor performance closely to confirm stability.
Posted Sep 11, 2025 - 09:56 EDT
This incident affected: Trello.com.