Trello is slow or unavailable
Incident Report for Trello
Resolved
The issue has been resolved.
Posted Jan 08, 2020 - 21:12 UTC
Monitoring
We have identified the issue and implemented a fix. We are currently monitoring the results.
Posted Jan 08, 2020 - 20:49 UTC
Investigating
Users may find that Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Jan 08, 2020 - 20:45 UTC