On June 2nd, Trello's search bar functionality was not working correctly. The issue has now been resolved, and the service operates normally for all affected customers.
Posted Jun 02, 2025 - 09:24 EDT
Monitoring
The issues causing Trello’s search bar functionality to malfunction have been resolved, and services are now operating normally for all affected customers. We will monitor it closely to ensure stability.
Posted Jun 02, 2025 - 09:19 EDT
Identified
We are currently experiencing an issue with Trello, as the search bar functionality is not working properly. We have identified the issue and are in the process of mitigating the impact. We'll keep you posted with further updates.
Posted Jun 02, 2025 - 08:58 EDT
Investigating
We are currently experiencing an issue with Trello, as the search bar functionality is not working properly. Our team is diligently working to restore services as quickly as possible. We will keep you updated with further developments.