Trello Connectivity Problems

Incident Report for Trello

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 17:12 EDT

Monitoring

We are now seeing recovery and monitoring.
Posted Aug 27, 2025 - 17:01 EDT

Investigating

We're receiving reports of connectivity problems while accessing Trello. You may see a "You are disconnected from Trello message" in the bottom left corner of your window notifying you that you've been disconnected.

We're currently investigating the cause, and will post updates here as we determine it.
Posted Aug 27, 2025 - 15:39 EDT
This incident affected: Trello.com.