Trello UI components not working as expected

Incident Report for Trello

Resolved

We can confirm the fix we released fixed the problems our users were experiencing with Trello's UI. Hence, we're closing this incident. Thanks for your patience and understanding.
Posted 2 years ago. Sep 25, 2023 - 16:28 EDT

Monitoring

We've identified the root cause of the problem that was affecting Trello's UI, and we've now released a new fix to it. We'll keep monitoring it from our side.
Posted 2 years ago. Sep 25, 2023 - 15:25 EDT

Investigating

We're investigating some reports from our users that Trello's UI isn't working as expected. We'll provide a new update soon!
Posted 2 years ago. Sep 25, 2023 - 15:19 EDT
This incident affected: Trello.com.