Trello is slow or unavailable

Incident Report for Trello

Resolved

This incident has been resolved.
Posted 3 years ago. Oct 19, 2022 - 16:14 EDT

Monitoring

Trello has recovered and is operating normally. We are continuing to investigate and monitor.
Posted 3 years ago. Oct 19, 2022 - 12:59 EDT

Investigating

Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted 3 years ago. Oct 19, 2022 - 12:28 EDT
This incident affected: Trello.com.