Between to , we experienced realtime update functionality degraded performance for Trello. We have mitigated the problem and are investigating the root cause. The issue has been resolved and the service is operating normally.
Posted Mar 05, 2025 - 14:44 EST
Monitoring
Between to , we experienced realtime update functionality degraded performance for Trello. We have mitigated the problem and are investigating the root cause. We are now monitoring closely.
Posted Mar 05, 2025 - 14:25 EST
Update
We are continuing our investigation on realtime updates that is impacting all Trello Cloud customers. We will provide more details within the next hour.
Posted Mar 05, 2025 - 13:19 EST
Update
We are still investigating realtime update errors that is impacting most Trello Cloud customers. We will provide more details within the next hour.
Posted Mar 05, 2025 - 11:55 EST
Investigating
We are investigating cases of degraded performance for SOME Trello Cloud customers. We will provide more details within the next hour.