Trello is slow
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 11:15 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2020 - 11:05 EST
Investigating
We've noticed that Trello is responding slowly and may be unusable for some users. This will be present in both the web and mobile apps.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted Feb 13, 2020 - 10:46 EST
This incident affected: Trello.com and API.