Trello is slow or unavailable
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Sep 27, 2021 - 04:59 EDT
Monitoring
Trello engineers have found the source of the problem, and site performance is back to normal. If you do continue to see any trouble, please reload Trello. If you still see issues, don't hesitate to reach out at https://trello.com/contact!
Posted Sep 27, 2021 - 04:23 EDT
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Sep 27, 2021 - 04:04 EDT
This incident affected: Trello.com and API.