Trello login and signup is slow or unresponsive
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 18:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 31, 2021 - 18:41 EDT
Identified
The issue has been identified and we are working with our partners to implement a fix.
Posted Aug 31, 2021 - 17:27 EDT
Investigating
We've noticed that Trello login and signup is responding slowly. This will be present in both the web and mobile apps.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted Aug 31, 2021 - 14:47 EDT
This incident affected: Trello.com.