Some Trello users might not receive email notifications instantly
Incident Report for Trello
Resolved
After further monitoring, this issue has been resolved by our engineers.
Posted 5 months ago. Apr 09, 2019 - 01:04 UTC
Monitoring
We've implemented a fix and are continuing to monitor.
Posted 5 months ago. Apr 09, 2019 - 00:56 UTC
Identified
The issue has been discovered and a fix is in progress.
Posted 5 months ago. Apr 09, 2019 - 00:53 UTC
Investigating
We're receiving internal reports that email notifications are sometimes not being received instantly, which may be affecting some Trello users.

Our engineers are currently investigating this issue and we will update here with more information.
Posted 5 months ago. Apr 09, 2019 - 00:42 UTC