Trello is slow or unavailable

Incident Report for Trello

Resolved

This incident has been resolved. If you are still experiencing any issues, please reach out to us at https://trello.com/contact.
Posted 3 years ago. Feb 08, 2022 - 12:02 EST

Monitoring

Monitoring: Trello service has been restored. We will continue to monitor the situation while we confirm the incident has been fully resolved.
Posted 3 years ago. Feb 08, 2022 - 09:16 EST

Investigating

Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted 3 years ago. Feb 08, 2022 - 08:19 EST
This incident affected: Trello.com and API.