Trello is slow
Incident Report for Trello
Resolved
Trello Engineering has resolved today's performance trouble; let us know if you still see anything out of place!
Posted Jul 21, 2021 - 12:05 EDT
Monitoring
Trello engineers believe they've found the source of the problem, and site performance is back to normal. If you do continue to see any trouble, please don't hesitate to reach out at https://trello.com/contact!
Posted Jul 21, 2021 - 11:45 EDT
Investigating
We've noticed that Trello is responding slowly. This will be present in both the web and mobile apps.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted Jul 21, 2021 - 09:59 EDT
This incident affected: Trello.com.