Trello is slow or unavailable
Incident Report for Trello
Resolved
Trello service and performance has been restored and is back to normal. If you're still having any trouble, please do reach out via https://trello.com/contact and we'll be glad to help!
Posted Feb 27, 2020 - 20:33 UTC
Monitoring
Our engineering team has restored Trello service and is monitoring to make sure full access is restored. If you're still having any trouble reaching Trello, please let us know via https://trello.com/contact!
Posted Feb 27, 2020 - 19:55 UTC
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Feb 27, 2020 - 19:41 UTC
This incident affected: Trello.com and API.