Trello is slow and/or not processing actions
Incident Report for Trello
Resolved
Our engineering team has already resolved and fixed all the issues caused by the connection spikes, including delays in card movements, general slowness, and board creation not processing.
Posted Dec 12, 2022 - 10:45 EST
Monitoring
Trello had an unexpected connection spike leading to symptoms such as cards being incorrectly moved and general slowness. The end-problem has been resolved and we are working on assessing the impact and following up on residual issues.
Posted Dec 12, 2022 - 09:48 EST
This incident affected: Trello.com and API.