On November 14, 2025 Trello users may have experienced delays on the execution of Trello automations. The issue has now been resolved, and the service is operating normally for all affected customers.
Note: All automations identified as impacted by this incident will be automatically rerun, no customer actions are needed to rerun these automations.
Posted Nov 14, 2025 - 15:30 EST
Monitoring
We have applied mitigations and continue to see improvements in Trello Automation processing times. However, some users may still experience delays in automation execution. We will provide another update by 20:45 UTC, or sooner if more information becomes available.
Posted Nov 14, 2025 - 14:49 EST
Identified
We have identified the cause of the issue, and our teams are diligently working on applying mitigations. We are seeing good signs of recovery, however, some users may experience some delays in Trello Automations executing. We’ll share additional updates at 19:45 UTC, or sooner, as more information is available.
Posted Nov 14, 2025 - 14:02 EST
Investigating
We are actively investigating reports of performance degradation affecting Trello automations. We'll share updates here as more information is available.