Trello is down

Incident Report for Trello

Resolved

We want to let you know that the changes we made on our side fixed all the connection issues our users were experiencing with Trello, and all services are functional right now. We appreciate your patience and understanding.
Posted 1 year ago. Nov 10, 2023 - 11:19 EST

Monitoring

The changes we released have fixed the connection issues our users were experiencing when connecting to Trello. We're now monitoring it.
Posted 1 year ago. Nov 10, 2023 - 10:47 EST

Update

We've identified the root cause of the issue, and we made some adjustments, which should bring Trello's functionalities back soon.
Posted 1 year ago. Nov 10, 2023 - 10:05 EST

Update

We are continuing to work on a fix for this issue.
Posted 1 year ago. Nov 10, 2023 - 09:45 EST

Identified

We've identified an issue on Trello that's affecting multiple users to connect to our servers. We'll provide a new update soon.
Posted 1 year ago. Nov 10, 2023 - 09:43 EST
This incident affected: Trello.com and API.