Trello is slow or unavailable
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 16:52 EST
Monitoring
Our engineering team has identified the cause of the incident and implemented a fix to restore Trello's service. We will continue to monitor the situation while we confirm the incident has been fully resolved.
Posted Jan 20, 2022 - 16:41 EST
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Jan 20, 2022 - 16:16 EST
This incident affected: Trello.com and API.