Trello users being unintentionally removed from boards
Incident Report for Trello
Resolved
The source of the issue has been resolved. We are continuing to investigate which users may have been impacted and how we can help them regain any lost access.

If you are concerned that you or a team member may have been affected by this, please reach out to us at support@trello.com or https://trello.com/contact, and we can assist further.
Posted 16 days ago. Mar 04, 2019 - 22:04 UTC
Monitoring
We have identified the cause and reverted the issue, preventing further impact. We are continuing to monitor the situation.
Posted 16 days ago. Mar 04, 2019 - 18:54 UTC
Investigating
We've received reports that users had been removed from boards unintentionally. Our engineers are currently investigating the cause, and we'll update here with more information.

You may see a red box in the top right corner of your window notifying you that you've been disconnected from the server. Please refresh your page if you see this.
Posted 16 days ago. Mar 04, 2019 - 17:29 UTC