Trello may be giving SSL connection errors
Incident Report for Trello
Resolved
Trello's Engineering team has resolved the problem. As always, if you're still having trouble, please do let us know at https://trello.com/contact

Some Butler commands that are setup to watch for events in Trello may not have run during this time, and will need to be manually rerun.
Posted Feb 15, 2020 - 00:21 UTC
Monitoring
Our team has a fix in place, and once updated DNS settings propagate to your computer, Trello access will be restored. If you're still having trouble, please don't hesitate to reach out via https://trello.com/contact
Posted Feb 15, 2020 - 00:04 UTC
Investigating
Some Trello customers are reporting SSL connection errors in accessing Trello.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

We will update this page as we have additional information.
Posted Feb 14, 2020 - 23:23 UTC
This incident affected: Web client.