Delays processing Billing Information
Incident Report for Trello
Resolved
Between 15:35 UTC to 17:08 UTC customers could not renew, downgrade or signup for a new subscription or update their billing information.

The issue has been resolved and the service is operating normally.
Posted Mar 02, 2023 - 14:40 EST
Monitoring
Between 15:35 UTC to 17:08 UTC customers could not renew, downgrade or signup for a new subscription or update their billing information.

The issue has been resolved and the service is operating normally.
Posted Mar 02, 2023 - 12:20 EST
This incident affected: Trello.com.