Trello - degraded performance (resolved)

Incident Report for Trello

Resolved

Search is now fully up to date for all users, and all issues with previous degraded functionality have been resolved.
Posted May 15, 2026 - 14:04 EDT

Monitoring

The team has resolved the previous issues and is now monitoring the system to ensure a full return to baseline. Search indexing is still approximately 1h delayed, but will be up to date shortly. Thank you for your patience
Posted May 15, 2026 - 13:36 EDT

Identified

The Trello team has identified and mitigated most of the issues with cards and comments. Users may still see delays in search indexing for short time while it catches up to realtime.
Posted May 15, 2026 - 12:40 EDT

Update

Trello engineers are actively working on resolving issues that our users may be seeing around commenting on cards, deleting comments, and adding new attachments. Users may also find that recent changes to cards are not reflected in search results. We are continuing to work on it and will provide more updates within the hour.
Posted May 15, 2026 - 11:31 EDT

Investigating

We are investigating degraded performance of some Trello features. We will provide more details within the next hour.
Posted May 15, 2026 - 11:14 EDT
This incident affected: Trello.com, API, Atlassian Support - Support Portal, Atlassian Support Ticketing, and Atlassian Support Knowledge Base.