Card covers not loading on web
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Dec 09, 2021 - 00:24 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2021 - 00:12 EST
Investigating
We've received reports of card covers not loading on web. Our team is currently investigating the issue.
Posted Dec 09, 2021 - 00:00 EST
This incident affected: Trello.com.