Trello search is down or slow for some users
Incident Report for Trello
Resolved
Trello search has been restored. Thank you for your patience.
Posted Oct 21, 2019 - 13:40 EDT
Monitoring
Trello search is now recovering. We will continue to monitor the situation.
Posted Oct 21, 2019 - 12:40 EDT
Update
We are continuing to investigate this issue and are working towards a resolution.
Posted Oct 21, 2019 - 12:06 EDT
Investigating
Our fix doesn't seem to have solved the issue for most users, we are continuing to work hard to resolve this issue
Posted Oct 21, 2019 - 10:35 EDT
Identified
We have discovered the issue and are rolling out a fix momentarily.
Posted Oct 21, 2019 - 09:51 EDT
Investigating
We're investigating reports of an issue with Trello's search functionality that seems to be causing problems for some users.

Updates will be posted here once we have more information.
Posted Oct 21, 2019 - 09:38 EDT