Trello is not loading for some users
Incident Report for Trello
Resolved
Access to Trello has stabilized, and the trouble with our partners have resolved. If you’re still having trouble, let us know at https://trello.com/contact
Posted Dec 18, 2020 - 23:10 UTC
Identified
Only a subset of Trello users are affected by this third-party incident, but as it's ongoing, users may still see interrupted access. We're keeping a close eye on updates!
Posted Dec 18, 2020 - 21:24 UTC
Monitoring
The problem has been isolated to a third-party network routing service, which contributed to some users temporarily unable to load trello.com. That issue is resolved now, and our engineering team is keeping an eye on it!
Posted Dec 18, 2020 - 20:43 UTC
Investigating
Trello may currently be slow or unavailable for some users.

Our engineering team is actively investigating this incident with our network partners to get everything back to normal.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Dec 18, 2020 - 20:17 UTC
This incident affected: Trello.com and API.