Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health (currently in Beta) to receive notifications if a reliability incident affects your organization.
On February 19, 2026, Trello users may have experienced performance degradation. The issue has now been resolved, and the service is operating normally for all affected customers.
Posted Feb 19, 2026 - 10:22 EST
Monitoring
The issue has been resolved, and services are now operating normally for all affected customers. We'll continue to monitor closely to confirm stability.
Posted Feb 19, 2026 - 10:10 EST
Investigating
We are actively investigating reports of performance degradation affecting Trello. We will share updates here as more information is available.
Posted Feb 19, 2026 - 10:06 EST
This incident affected: Trello.com, API, Atlassian Support - Support Portal, Atlassian Support Ticketing, and Atlassian Support Knowledge Base.