Trello search is down or slow for some users
Incident Report for Trello
Resolved
This incident has been resolved.
Posted 29 days ago. Sep 23, 2019 - 20:45 UTC
Monitoring
We have implemented a fix for the issues we were seeing and are now watching closely as the system recovers. Trello search is once again operational.
Posted 30 days ago. Sep 23, 2019 - 14:49 UTC
Investigating
We're currently investigating an issue with Trello's search functionality that seems to be causing problems for users. Updates will be posted here once we have more information.
Posted 30 days ago. Sep 23, 2019 - 14:33 UTC