Degraded experience adding and accessing media attachments

Incident Report for Trello

Resolved

We have resolved this incident.
Posted Jul 30, 2025 - 04:13 EDT

Investigating

We are currently investigating this issue.
Posted Jul 30, 2025 - 03:16 EDT
This incident affected: Trello.com.