Trello is slow
Incident Report for Trello
Resolved
This incident is resolved, and Trello is back to normal operation.
Posted Jun 03, 2020 - 16:48 UTC
Monitoring
Our engineering has resolved the problem and is keeping an eye on things. If you're still having any trouble, please let us know at https://trello.com/contact!
Posted Jun 03, 2020 - 15:52 UTC
Investigating
Trello is currently responding slowly. This may be present in both the web and mobile apps.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted Jun 03, 2020 - 15:02 UTC
This incident affected: Trello.com.