Trello is slow or unavailable for some users

Incident Report for Trello

Resolved

This incident has been resolved.
Posted Sep 28, 2021 - 15:47 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2021 - 15:43 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 28, 2021 - 15:27 EDT

Update

We are continuing to investigate intermittent performance issues.
Posted Sep 28, 2021 - 15:07 EDT

Investigating

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Sep 28, 2021 - 14:36 EDT
This incident affected: Trello.com and API.