Trello is partially slow and issues to execute card changes
Incident Report for Trello
Resolved
We want to confirm that the fix the engineering team has implemented solved the Trello slowness and unavailability our users were experiencing today.
Posted Jan 24, 2023 - 12:41 EST
Monitoring
Our engineering team implemented a fix for this issue and is seeing ongoing recovery. There may still be some slight performance degradation which is recovering as well.

We will update this page as we have additional information.
Posted Jan 24, 2023 - 11:56 EST
Identified
Trello is currently experiencing partial slowness and unavailability to execute card changes across multiple boards within Trello.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or unavailability to execute card changes on the web, desktop, and mobile apps.

We will update this page as we have additional information.
Posted Jan 24, 2023 - 11:50 EST
This incident affected: Trello.com and API.