Trello is slow or unavailable
Incident Report for Trello
Resolved
Our engineering teams have found the source of the problem and both Trello and Butler are back up and running normally. If you're still having any trouble, please don't hesitate to reach out via https://trello.com/contact and we'll be happy to help!
Posted Jan 06, 2020 - 18:00 UTC
Identified
Our engineering teams have identified the problem and are working towards a resolution. Trello performance is improving. Butler is temporarily down while we continue investigating.
Posted Jan 06, 2020 - 16:34 UTC
Investigating
Trello may currently be slow or unavailable and present errors when loading boards.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Jan 06, 2020 - 15:07 UTC