Email-to-Board not creating cards
Incident Report for Trello
Resolved
Our team is confident the problem has been resolved, and was able to restore all email messages sent during the downtime. If you're still running into any trouble, please don't hesitate to reach out via https://trello.com/contact!
Posted 4 months ago. Jun 28, 2019 - 20:00 UTC
Monitoring
Our team's rolled back the change that we believe was the cause and have a fix in place. We're monitoring to make sure that the problem is solved.

We're looking into restoring the emails that were sent during the downtime.
Posted 4 months ago. Jun 28, 2019 - 18:15 UTC
Investigating
Our team has discovered a problem with Trello's Email-to-Board feature not creating cards, and are working on a resolution. We'll update with more information as soon as possible!
Posted 4 months ago. Jun 28, 2019 - 17:55 UTC