Attachments, avatars, and board backgrounds may not be loading

Incident Report for Trello

Resolved

This incident has been resolved
Posted Oct 23, 2019 - 00:46 EDT

Investigating

Our team is investigating a problem with our file hosting service and this may be affecting the loading and performance of attached files, avatars, and board backgrounds. The team is investigating.
Posted Oct 22, 2019 - 15:38 EDT