Trello board creation is failing when using image search results — Investigating
Incident Report for Trello
Resolved
Our team identified a resolution to the issue. Thanks for your patience.
Posted Sep 25, 2019 - 16:27 EDT
Investigating
Trello board creation is failing when using image search results.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted Sep 25, 2019 - 16:05 EDT