Atlassian Cloud email notifications issue
Incident Report for Trello
Resolved
Between 11:58 UTC to 13:15 UTC, we experienced outgoing emails for Trello. The issue has been resolved and the service is operating normally.
Posted 27 days ago. Jun 19, 2019 - 13:24 UTC
Investigating
We are investigating an issue with outgoing email that is impacting some Atlassian Cloud customers. We will provide more details within the next hour.
Posted 27 days ago. Jun 19, 2019 - 11:58 UTC