Trello Help section is slow or unavailable
Incident Report for Trello
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 17:08 UTC
Investigating
Some users may find that the Help section of Trello (https://help.trello.com/) is currently slow or unavailable.

We are investigating this issue and working to bring the Help section back online as soon as possible. Trello itself is not affected by this.

We will update this page as we have additional information.
Posted Dec 02, 2019 - 16:19 UTC