Trello is slow or unavailable

Incident Report for Trello

Resolved

The issue has been resolved. If you are still experiencing any issues, please don't hesitate to reach out to us at https://trello.com/contact.
Posted 3 years ago. Dec 22, 2021 - 14:21 EST

Update

Trello has now recovered. We’ll continue to monitor this while we wait for confirmation from our third-party vendor that the root cause has been resolved
Posted 3 years ago. Dec 22, 2021 - 10:11 EST

Monitoring

We've seeing some recovery and continuing to monitor the performance of both our web and mobile apps.
Posted 3 years ago. Dec 22, 2021 - 09:08 EST

Update

We're continuing to investigate this issue and will let you know as soon as we have updates.
Posted 3 years ago. Dec 22, 2021 - 08:20 EST

Investigating

We've noticed that Trello is responding slowly or unavailable. This will be present in both the web and mobile apps.

Our engineering team is actively investigating this incident and working to bring Trello back up to speed as quickly as possible.

We'll keep you posted with further updates on this page.
Posted 3 years ago. Dec 22, 2021 - 07:31 EST
This incident affected: Trello.com.