Delay is processing some Trello Billing information.
Incident Report for Trello
Resolved
Between 16:45 UTC to 19:00 UTC customers could not renew, downgrade or signup for a new subscription.

The issue has been resolved and the service is operating normally.
Posted Feb 27, 2023 - 15:50 EST
Update
Our engineers have identified the problem and are working on a fix. Next update will be within the next hour.

This problem impacts customers attempting to renew, downgrade or signup for a new subscription.

Customers can continue to change other aspects of their billing information such as credit card information and billing admin which is not impacted by this problem.
Posted Feb 27, 2023 - 14:16 EST
Identified
We are experiencing delays processing Trello Billing information changes. This includes customers signing up for subscriptions in addition to customers updating other parts of their billing information.

Our engineers have identified the problem and are working on a fix.

Next update in one hour.
Posted Feb 27, 2023 - 13:10 EST
This incident affected: Trello.com.