Organization administrators can now receive personalized incident information in Atlassian Administration. Subscribe to System Health (currently in Beta) to receive notifications if a reliability incident affects your organization.
We are continuing to work with our public cloud provider to mitigate this issue. We are starting to see some recovery in regions outside of Eastern USA, however, users globally may still be experiencing issues with certain product features. These are listed at the bottom of each product page.
Posted May 08, 2026 - 00:10 EDT
Update
Our teams continue to work on mitigating the infrastructure outage from our public cloud provider. We will provide further updates when they are available.
Posted May 08, 2026 - 00:10 EDT
Update
We have identified that the root cause of the issue is related to an infrastructure outage from our public cloud provider. We are working closely with them to mitigate this issue. We will provide further updates when they become available.
Posted May 08, 2026 - 00:10 EDT
Update
Our teams continue to work on mitigating the infrastructure outage from our public cloud provider. We will provide further updates when they are available.
Posted May 07, 2026 - 23:00 EDT
Update
We have identified that the root cause of the issue is related to an infrastructure outage from our public cloud provider. We are working closely with them to mitigate this issue. We will provide further updates when they become available.
Posted May 07, 2026 - 23:00 EDT
Identified
We have identified that the root cause of the issue is related to an infrastructure outage from our public cloud provider. We are working closely with them to mitigate this issue. We will provide further updates when they become available.
Posted May 07, 2026 - 22:15 EDT
Investigating
We are experiencing issues with multiple Atlassian products. Our teams are investigating further and more updates including will be shared within 1 hour.
Posted May 07, 2026 - 21:31 EDT
This incident affects: Trello.com, API, Atlassian Support - Support Portal, Atlassian Support Ticketing, and Atlassian Support Knowledge Base.