Managing workspace members is failing for some workspace administrators

Incident Report for Trello

Resolved

A fix has been deployed. Thank you for your patience.
Posted Apr 09, 2024 - 16:02 EDT

Identified

We have identified the root cause and are working towards releasing a fix.
Posted Apr 09, 2024 - 14:16 EDT

Investigating

We are currently investigating this issue.
Posted Apr 09, 2024 - 13:24 EDT
This incident affected: Trello.com.