Trello is slow or unavailable
Incident Report for Trello
Resolved
The issue has been resolved. If you are still experiencing any issues, please don't hesitate to reach out to us at https://trello.com/contact.
Posted Feb 02, 2022 - 09:31 EST
Monitoring
Our engineering team has identified the cause of the incident and implemented a fix to restore Trello's service. We will continue to monitor the situation while we confirm the incident has been fully resolved.
Posted Feb 02, 2022 - 08:57 EST
Update
We are continuing to investigate this issue.
Posted Feb 02, 2022 - 08:56 EST
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Feb 02, 2022 - 08:34 EST
This incident affected: Trello.com.