Trello is slow or unavailable
Incident Report for Trello
Resolved
The incident has been resolved, and we're back up and running!
Posted Jun 02, 2020 - 15:13 UTC
Monitoring
We are back up and our engineering team is continuing to monitor the situation.
Posted Jun 02, 2020 - 14:36 UTC
Update
We are continuing to investigate the issue and hope to have an update soon!
Posted Jun 02, 2020 - 14:29 UTC
Investigating
Users may find that Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Jun 02, 2020 - 13:42 UTC
This incident affected: Trello.com and API.