Trello Signup not working
Incident Report for Trello
Resolved
Trello Engineers have identified and resolved the issue.
Posted Aug 04, 2021 - 10:41 EDT
Investigating
Signing up for a new Trello Account is failing and not creating a new account. Trello Engineers are investigating and we'll get things back up and working as soon as we can!
Posted Aug 04, 2021 - 10:25 EDT
This incident affected: Trello.com and API.