Degraded performance in Cloud
Incident Report for Trello
Resolved
The issues with Trello have been mitigated and the incident is being marked resolved for Trello.
Posted Sep 18, 2023 - 17:37 EDT
Monitoring
An outage with a cloud provider is impacting multiple Atlassian Cloud products including Access, Confluence, Trello, and Jira Products. We will provide more details within the next hour.
Posted Sep 18, 2023 - 16:44 EDT
This incident affected: Trello.com and API.