Following a period of monitoring, we've confirmed that the issue with degraded performance in Trello has been resolved. For any further issues please contact our Support team.
Posted 25 days ago. Mar 11, 2025 - 09:30 EDT
Monitoring
Trello is back up and running and we're not seeing any more performance issues but we'll continue to monitor this. If you're still experiencing any performance issues, please reach out to us through our support channels for further assistance
Posted 25 days ago. Mar 11, 2025 - 08:59 EDT
Update
We're still looking into issues with degraded performance in Trello and our team are working to get Trello back up and running as quickly as possible. We'll post more updates on this shortly.
Posted 25 days ago. Mar 11, 2025 - 07:33 EDT
Investigating
We're continuing to investigate issues causing degraded performance in Trello for some Trello customers.
We'll post more updates on this shortly.
Posted 25 days ago. Mar 11, 2025 - 06:43 EDT
Monitoring
Our team have implemented a fix and we're seeing performance improve, we'll continue to monitor this to make sure everything is working as normal.
Posted 25 days ago. Mar 11, 2025 - 05:50 EDT
Investigating
We're currently investigating an issue that's causing degraded performance in Trello for some customers and our team are working to get Trello back up and running as quickly as possible.