Issues with the Jira powerup
Incident Report for Trello
Resolved
The issues with the Jira powerup have been resolved!
Posted Jun 27, 2024 - 04:35 EDT
Identified
Users of the Jira powerup for Trello may be experiencing errors when installing and using the powerup on their boards.

The team is working to resolve this issue as quickly as possible.
Posted Jun 27, 2024 - 03:57 EDT
This incident affected: Trello.com.