Trello is slow or unavailable
Incident Report for Trello
Postmortem

On 10-26-2020 between 17:28 UTC and 17:55 UTC, Atlassian customers using Trello may have experienced the Trello web client, API and mobile apps being unavailable.

This incident was caused by a deploy containing a change which inadvertently increased the number of queries against our database. Our response team was alerted as request times throughout the system began slowing and responded by rolling back to a stable version of Trello and blocking requests through the API to reduce load and allow the system to recover.

We understand that outages negatively impact your productivity, so we are taking the following actions to prevent similar incidents in the future. We will be implementing a change to detect increases in queries against our database prior to deploying changes to users and improving our alerting so that the response team can help prevent a full outage when load begins to increase on our database.

We apologize for the inconvenience this has caused. Please reach out to us if you would like more details.

Posted Nov 02, 2020 - 13:05 EST

Resolved
This incident has been resolved.
Posted Oct 26, 2020 - 14:15 EDT
Monitoring
Trello services are available again, and we are continuing to monitor.
Posted Oct 26, 2020 - 14:07 EDT
Investigating
Trello is currently slow or unavailable.

Our engineering team is actively investigating this incident and working to bring Trello back up as quickly as possible.

Users affected by this incident may notice that Trello is slow or completely unavailable in both the web and mobile apps.

We will update this page as we have additional information.
Posted Oct 26, 2020 - 13:35 EDT
This incident affected: Trello.com and API.